Degraded performance

Incident Report for Logos Payment Solutions A/S

Postmortem

Postmorten will be created after the investigation has been concluded.

Posted May 31, 2026 - 13:37 CEST

Resolved

Vi oplever forringet drift/ We are experiencing degraded performance
Posted May 31, 2026 - 09:30 CEST